Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Balu42  
#1 Posted : 01 March 2014 03:57:45(UTC)
Balu42

Rank: Newbie

Groups: Registered
Joined: 25/09/2013(UTC)
Posts: 5
United States
Location: Las Vegas, NV

Hi,

I have tried to post this in the SMath Studio 0.97.5154 (10 February 2014) topic but it said something about a moderator needs to approve my post and it never appeared there so I am giving it a try here.

I am running SMath Studio 0.97.5154 and also SMath Studio 0.96.4868 under Red Hat Enterprise Linux 6 using Mono 2.10.6.

When I open the new Extensions Manager panel in SMath Studio 0.97.5154 it opens and works fine. I can double click on Snippets or Examples and the window closes with no problem and the material gets inserted into my page but if I ever attempt to close that panel by clicking on the X in the upper right corner the program crashes. The message displayed in Terminal is the following:

$ mono SMathStudio_Desktop.exe
Stack overflow: IP: 0x5c5b5b, fault addr: (nil)
Stacktrace:
at (wrapper alloc) object.Alloc (intptr) <0xffffffff>
<...>
at System.Windows.Forms.Hwnd.ObjectFromHandle (intptr) <0x00047>
at System.Windows.Forms.Control.get_IsHandleCreated () <0x00073>
at System.Windows.Forms.TreeView.get_SelectedNode () <0x0000f>
at (wrapper remoting-invoke-with-check) System.Windows.Forms.TreeView.get_SelectedNode () <0xffffffff>
at .. () <0x0002b>
at .. (object,System.Windows.Forms.FormClosingEventArgs) <0x0003f>
at System.Windows.Forms.Form.OnFormClosing (System.Windows.Forms.FormClosingEventArgs) <0x00069>
at System.Windows.Forms.Form.FireClosingEvents (System.Windows.Forms.CloseReason,bool) <0x00084>
at System.Windows.Forms.Form.RaiseCloseEvents (bool,bool) <0x0007f>
at System.Windows.Forms.Form.set_DialogResult (System.Windows.Forms.DialogResult) <0x00043>
at .. (object,System.Windows.Forms.FormClosingEventArgs) <0x0008b>

From this point on the last 5 rows keep repeating until I kill the process.

Could someone help me figuring out if this is a bug in SMath Studio 0.97.5154 or is a problem with my Mono installation and if it is my Mono, how to fix it?

Thank you,
Balu
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.