Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Andrey Ivashov  
#1 Posted : 31 January 2019 21:52:40(UTC)
Andrey Ivashov


Rank: Administration

Groups: Developers, Registered, Knovel Developers, Administrators, Advanced Member
Joined: 11/07/2008(UTC)
Posts: 1,319
Man
Russian Federation

Was thanked: 1507 time(s) in 507 post(s)

New Beta SMath Studio 0.99.6970 is available!

Tiny, powerful, free mathematical program with WYSIWYG editor and complete units of measurements support.

It provides numerous computing features and rich user interface translated into about 40 different languages. Application also contains integrated mathematical reference book.

SMath Studio boxCalculation of Gravitation Acceleration exampleExample of animation on the WorksheetExtensions Manager toolOpened math Reference BookSMath Viewer output to Autocad exampleSMath Studio on iOSSMath Studio on iPad

Application can be easily extended based on your needs. Built-in Extensions Manager tool allows to get access to hundreds official and third-party resources of the following types: usage examples, plug-ins, SMath Viewer based applications, snippets, interface translations, interactive books, handbooks and tutorials.

Changes introduced in current build

Improvements

  • Part of the equation which causes an error is highlighted now;
  • It is now allowed to move regions within Header/Footer on all pages (previously it was possible on the first page only).

Corrections

  • Moving regions between pages (with incorrect vertical position after region drop) fixed;
  • Rendering of the worksheet improved for small zoom values;
  • Support for evaluation plug-ins improved.

Download

Software icon SMathStudioDesktop.0_99_6970.Setup.msi (Date: 2019.01.31; File size: 2.23 MB) - 296 downloads
Software icon SMathStudioDesktop.0_99_6970.Mono.tar.gz (Date: 2019.01.31; File size: 1.36 MB) - 49 downloads


err_show_1.PNG

Please note:
  1. There are some known bugs with Worksheet scrolling - will be addressed soon.

Edited by user 12 February 2019 18:50:05(UTC)  | Reason: Not specified

thanks 6 users thanked Andrey Ivashov for this useful post.
on 31/01/2019(UTC),  on 31/01/2019(UTC),  on 31/01/2019(UTC),  on 01/02/2019(UTC),  on 01/02/2019(UTC),  on 01/02/2019(UTC)
Offline bambrr  
#2 Posted : 04 February 2019 15:16:52(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

при єкспорте в формат odt выдает ошибку
Offline Davide Carpi  
#3 Posted : 05 February 2019 02:42:35(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,084
Man
Italy
Location: Italy

Was thanked: 1059 time(s) in 698 post(s)
Originally Posted by: bambrr Go to Quoted Post
при єкспорте в формат odt выдает ошибку


I'm unable to reproduce. Can you attach the file that cannot be saved as odt?
Best regards,

Davide

---
If you like my plugins please consider making a donation to SMath Studio
Offline bambrr  
#4 Posted : 05 February 2019 12:26:57(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

Originally Posted by: Davide Carpi Go to Quoted Post
Originally Posted by: bambrr Go to Quoted Post
при экспорте в формат odt выдает ошибку


I'm unable to reproduce. Can you attach the file that cannot be saved as odt?


ras.sm (26kb) downloaded 14 time(s). ras.sm (26kb) downloaded 14 time(s).
Offline Davide Carpi  
#5 Posted : 05 February 2019 13:28:56(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,084
Man
Italy
Location: Italy

Was thanked: 1059 time(s) in 698 post(s)
I tried SS 0.99.6962 and 0.99.6970 with different localization options and I can save without errors. Please post even the error message when you can (with the stack trace, if any). Anyone else notice issues?
Best regards,

Davide

---
If you like my plugins please consider making a donation to SMath Studio
Offline ElSid  
#6 Posted : 05 February 2019 19:50:38(UTC)
ElSid


Rank: Advanced Member

Groups: Registered
Joined: 05/03/2009(UTC)
Posts: 279
Man
United States
Location: USA

Was thanked: 9 time(s) in 8 post(s)
New computer Win 7 install with the Beta Version. No errors about plugins being missingEval.PNG
Offline bambrr  
#7 Posted : 06 February 2019 17:37:25(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

1.jpg (655kb) downloaded 15 time(s).
Originally Posted by: Davide Carpi Go to Quoted Post
I tried SS 0.99.6962 and 0.99.6970 with different localization options and I can save without errors. Please post even the error message when you can (with the stack trace, if any). Anyone else notice issues?


Offline uni  
#8 Posted : 06 February 2019 20:05:15(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 886
Man
Russian Federation

Was thanked: 789 time(s) in 453 post(s)
Originally Posted by: bambrr Go to Quoted Post
при єкспорте в формат odt выдает ошибку

Нужно указать больше информации об окружении: версия Windows, версия SMath Studio (+разрядность), версия используемого плагина (Data Exchange). Трудно без этой информации воспроизвести и решить проблему. Мне тоже не удалось её повторить.
Russia forever!
Viacheslav N. Mezentsev
💰 You can support me for plugins development: https://paypal.me/viacheslavmezentsev
Offline Davide Carpi  
#9 Posted : 06 February 2019 20:34:39(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,084
Man
Italy
Location: Italy

Was thanked: 1059 time(s) in 698 post(s)
It is possible that you don't have .NET 2.0/3.5 installed or enabled on your system (System.Web isn't available in .NET framework 4+ AFAIK). Please download the development tools plugin and then from "Insert > Development tools > System informations" paste the data here.
Best regards,

Davide

---
If you like my plugins please consider making a donation to SMath Studio
Offline bambrr  
#10 Posted : 07 February 2019 11:37:21(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

Originally Posted by: uni Go to Quoted Post
Originally Posted by: bambrr Go to Quoted Post
при єкспорте в формат odt выдает ошибку

Нужно указать больше информации об окружении: версия Windows, версия SMath Studio (+разрядность), версия используемого плагина (Data Exchange). Трудно без этой информации воспроизвести и решить проблему. Мне тоже не удалось её повторить.


Windows 7
SMath Studio Desktop 64 бит. ver. 0.99 сборка 6977
Data Exchange 1.1.6858.3747
Offline bambrr  
#11 Posted : 07 February 2019 11:50:00(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

Originally Posted by: Davide Carpi Go to Quoted Post
It is possible that you don't have .NET 2.0/3.5 installed or enabled on your system (System.Web isn't available in .NET framework 4+ AFAIK). Please download the development tools plugin and then from "Insert > Development tools > System informations" paste the data here.


NET framework 4 is installed on the system Sad
Offline Davide Carpi  
#12 Posted : 07 February 2019 13:36:47(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,084
Man
Italy
Location: Italy

Was thanked: 1059 time(s) in 698 post(s)
Originally Posted by: bambrr Go to Quoted Post
NET framework 4 is installed on the system


In mine too; but what about previous versions?

Code:
CLR 4.0.30319.42000

	installed versions:
	v2.0.50727	2.0.50727.4927 SP2
	v3.0	3.0.30729.4926 SP2
	v3.5	3.5.30729.4926 SP1
	v4	
		Client	4.7.03056
		Full	4.7.03056
	v4.0	
		Client	4.0.0.0


2019-02-07 11_32_07-Window.png
Best regards,

Davide

---
If you like my plugins please consider making a donation to SMath Studio
Offline bambrr  
#13 Posted : 07 February 2019 15:01:15(UTC)
bambrr

Rank: Newbie

Groups: Registered
Joined: 07/06/2016(UTC)
Posts: 6
Ukraine
Location: Kharkov

Originally Posted by: Davide Carpi Go to Quoted Post
Originally Posted by: bambrr Go to Quoted Post
NET framework 4 is installed on the system


In mine too; but what about previous versions?


0.jpg

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.