Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Albedo  
#1 Posted : 30 August 2022 05:24:23(UTC)
Albedo

Rank: Newbie

Groups: Registered
Joined: 30/08/2022(UTC)
Posts: 6
United States

Trying to solve a very complex system of equations containing 3 sets of equations. However it keeps appearing to get stuck at 46/47 processed. Not sure why this is happening, I have a very high powered PC since I have to run FEA with millions of elements. So an equation like this should be a breeze. Here is what the sheet looks like: https://imgur.com/a/r0JVOje Attached is the file if you want to dig around and try to get it to spit out the three values I need. Any help is GREATLY appreciated. Stresses.sm (37kb) downloaded 12 time(s).

EDIT: found an error, didn't change sigma.1h.1 to sigma.1. Problem still persists even after the change.

Edited by user 30 August 2022 05:39:38(UTC)  | Reason: Not specified

Offline PompelmoTell  
#2 Posted : 30 August 2022 11:50:00(UTC)
PompelmoTell


Rank: Advanced Member

Groups: Registered
Joined: 23/12/2011(UTC)
Posts: 307
Man
Italy
Location: italy

Was thanked: 106 time(s) in 90 post(s)
I seem to be able to say that there are several errors is formal in the use of Smath and the Maxima plugin but also of the engineering problem. I report you:
- The three equations do not require a solutor because each contains a single unknown
- The way of recalling the "Solve" function is not appropriate (the three equations must be inserted in a vector or system. Even the unknowns must be inserted in a vector)
- The first two equations were written correctly with = the third instead with :=
- The second equation is not consistent as it is dimensionally we have a stress (MPa) obtained as the sum of elements that are not stress (1/MPa)

Consult Martin Kraska's interactive guide for the correct use of Solve

sergio
Offline Albedo  
#3 Posted : 30 August 2022 22:19:24(UTC)
Albedo

Rank: Newbie

Groups: Registered
Joined: 30/08/2022(UTC)
Posts: 6
United States

Originally Posted by: PompelmoTell Go to Quoted Post
I seem to be able to say that there are several errors is formal in the use of Smath and the Maxima plugin but also of the engineering problem. I report you:
- The three equations do not require a solutor because each contains a single unknown
- The way of recalling the "Solve" function is not appropriate (the three equations must be inserted in a vector or system. Even the unknowns must be inserted in a vector)
- The first two equations were written correctly with = the third instead with :=
- The second equation is not consistent as it is dimensionally we have a stress (MPa) obtained as the sum of elements that are not stress (1/MPa)

Consult Martin Kraska's interactive guide for the correct use of Solve

sergio


Thanks for the reply!

- thanks for catching that! I wrote the last part of the equation incorrectly, it should be everything multiplied by E.I instead of divided by.
- ahhh, I see the equations looked a lot more complicated than they were. I was able to get it to solve by setting one of the equations to a boolean equal and now it gives me the values I am looking for.

Thanks for your help solving this!

EDIT: Nevermind, error still persists. Cleaning out the old equations that were just trial got rid of the solution and it keeps saying the values are "undefined". Tried tossing it back into the solver with the corrected formatting, still won't solve it. Stresses.sm (33kb) downloaded 5 time(s). Here is the updated sheet.

So how do I get this to solve for the three values?

I should note, in Maxima debug, when trying to evaluate it Maxima returns "no data"

Edited by user 30 August 2022 22:50:24(UTC)  | Reason: Not specified

Offline overlord  
#4 Posted : 30 August 2022 23:07:24(UTC)
overlord


Rank: Advanced Member

Groups: Registered
Joined: 23/07/2013(UTC)
Posts: 853
Turkey

Was thanked: 320 time(s) in 220 post(s)
Originally Posted by: Albedo Go to Quoted Post
So how do I get this to solve for the three values?

I use linux, so I can't use Maxima plugin.
However, your functions can be solved with al_nleqsolve().
I don't know if it is correct in terms of engineering.
I just solved it only regards to an SMath Solver sample.

Regards

Stresses(1).sm (50kb) downloaded 10 time(s).

Click to enlarge
Offline Albedo  
#5 Posted : 30 August 2022 23:22:30(UTC)
Albedo

Rank: Newbie

Groups: Registered
Joined: 30/08/2022(UTC)
Posts: 6
United States

Originally Posted by: overlord Go to Quoted Post
Originally Posted by: Albedo Go to Quoted Post
So how do I get this to solve for the three values?

I use linux, so I can't use Maxima plugin.
However, your functions can be solved with al_nleqsolve().
I don't know if it is correct in terms of engineering.
I just solved it only regards to an SMath Solver sample.

Regards

Stresses(1).sm (50kb) downloaded 10 time(s).

Click to enlarge


Thanks for the reply and attempting to solve this! The values are extremely low, I am expecting them to be around 50-200 MPa. Something must be wrong here, even when I change the wall thickness, the values barely change. The wall thickness is the major determinant (t.1, t.2) in these equations for stresses. I think it might be useful to drop the link to where the equations came from: https://ocw.mit.edu/courses/16-512-rocket-propulsion-fall-2005/357a8f245e0020bcfa43530ba6ed1283_lecture_9.pdf In there example they routinely got around 200 MPa but were using a thinner wall, when I tossed their thicknesses in, the values were still absurdly small.

Edited by moderator 31 August 2022 00:06:09(UTC)  | Reason: file link

Offline mkraska  
#6 Posted : 31 August 2022 17:33:48(UTC)
mkraska


Rank: Advanced Member

Groups: Registered
Joined: 15/04/2012(UTC)
Posts: 1,757
Germany

Was thanked: 967 time(s) in 615 post(s)
The problems with Solve() seem to be due to translation problems of names like sigma_1.1, where the period as part of the subscript is not escaped.

Unfortunately, this error is not catched, so that the Maxima process gets stuck (restart using either MaximaControl("restart"Wink or using Insert> Maxima> Settings> Save and restart)

With modified names, a solution can be obtained.

Stresses_Kr.sm (32kb) downloaded 6 time(s).
Stresses_Kr.png
Martin Kraska

Pre-configured portable distribution of SMath Studio: https://en.smath.info/wi...th%20with%20Plugins.ashx
thanks 1 user thanked mkraska for this useful post.
on 31/08/2022(UTC)
Offline Razonar  
#7 Posted : 31 August 2022 18:48:58(UTC)
Razonar


Rank: Advanced Member

Groups: Registered
Joined: 28/08/2014(UTC)
Posts: 1,031
Uruguay

Was thanked: 575 time(s) in 370 post(s)
Originally Posted by: Albedo Go to Quoted Post
...
Thanks for the reply and attempting to solve this! The values are extremely low, I am expecting them to be around 50-200 MPa. Something must be wrong here, ...


Hi. From your source, the system is with equations (7), (10) and (13) and "From here, we either solve for σ2h, σ2c, σ1 (given geometry, Pg, Pl, Pq) or, for design, go the reverse route and decide on the geometry for assigned stresses."

I see equations (7) and (10) but for equation (13) I guess that there are something wrong there in the equations system to be solved.

Best regards.
Alvaro.
Offline overlord  
#8 Posted : 01 September 2022 01:59:05(UTC)
overlord


Rank: Advanced Member

Groups: Registered
Joined: 23/07/2013(UTC)
Posts: 853
Turkey

Was thanked: 320 time(s) in 220 post(s)
Actually, FindRoot() works with your function too.
It only requires to disable these variables.

2022-08-31_23-27_1.png

After that, function worked as expected. Unknowns() is important btw.
Solvers find results according to order of Unknowns() output order.
Otherwise one would require to check which result is for which variable.

Regards

2022-08-31_23-28.png
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.