Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline mkraska  
#1 Posted : 23 April 2022 00:07:52(UTC)
mkraska


Rank: Advanced Member

Groups: Registered
Joined: 15/04/2012(UTC)
Posts: 1,735
Germany

Was thanked: 952 time(s) in 604 post(s)
In SMath Solver 7921, it seems that some characters typed into string constants are coded even if they are in the basic ascii set.
In SMath Studio 7822 (latest installed version on my computer) this problem does not appear.

Here is an example which drives the user mad if he doesn't suspect about string encoding.

Even inspecting of the xml source in notepad++ doesn't reveal the difference, obviously the encoding is hidden from the user.
Only pasting from clipboard to notepad++ did help.
In the maxima translation process, a difference is seen on maxima side, yet it is hidden when back-translated.

IMHO string comparison or identity check in general should account for such encoding issues.

findrows.sm (12kb) downloaded 7 time(s).
findrows.png

Martin Kraska

Pre-configured portable distribution of SMath Studio: https://en.smath.info/wi...th%20with%20Plugins.ashx
Offline overlord  
#2 Posted : 25 April 2022 02:00:32(UTC)
overlord


Rank: Advanced Member

Groups: Registered
Joined: 23/07/2013(UTC)
Posts: 788
Turkey

Was thanked: 280 time(s) in 198 post(s)
Can this be a Microsoft character encoding issue?
I am also on v7921 and opened your file directly.
There is no issue on linux mono.

Regards

2022-04-25_01-54.png
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.