Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline zapzapouch  
#1 Posted : 14 July 2014 18:34:46(UTC)
zapzapouch


Rank: Member

Groups: Registered
Joined: 03/07/2014(UTC)
Posts: 27
United States

I had a worksheet that worked in the past, but now it doesn't, saying "operation cannot be performed with units", because it's sqrt(V^2)? But if I break it up into two steps it works:

File Attachment(s):
resistor noise fail.sm (7kb) downloaded 32 time(s).
Offline Davide Carpi  
#2 Posted : 14 July 2014 19:43:55(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,487
Man
Italy
Location: Italy

Was thanked: 1239 time(s) in 819 post(s)
Works for me with SMath 0.97.5301, but I see you are using 0.97.5154

Could you try to open your file with the latest Nightly build?
Davide Carpi attached the following image(s):
2014-07-14 18_44_11-SMath Studio Desktop - [resistor noise fail.sm].png
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Offline zapzapouch  
#3 Posted : 14 July 2014 19:52:13(UTC)
zapzapouch


Rank: Member

Groups: Registered
Joined: 03/07/2014(UTC)
Posts: 27
United States

yes, it works in the Nightly build. thanks.

by the way, the email notification links never work. I always get

"There has been a serious error loading the forum. No further information is available.

Please contact the administrator if this message persists."

and have to find the topic manually
Offline zapzapouch  
#4 Posted : 14 July 2014 19:57:40(UTC)
zapzapouch


Rank: Member

Groups: Registered
Joined: 03/07/2014(UTC)
Posts: 27
United States

Actually, no, the original worksheet is not working, only the copy that I uploaded

File Attachment(s):
Basic stuff.sm (12kb) downloaded 32 time(s).
Offline Davide Carpi  
#5 Posted : 14 July 2014 20:23:39(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,487
Man
Italy
Location: Italy

Was thanked: 1239 time(s) in 819 post(s)
I've already seen this bug, sometimes comes to light... Grabli

when the SMath engine output unitary exponents on units, square root fails.

Refreshing the worksheet alternately works/doesn't works.


[EDIT] Added in the BTS: SS-177

Edited by user 15 July 2014 01:20:03(UTC)  | Reason: Not specified

Davide Carpi attached the following image(s):
2014-07-14 19_20_40-SMath Studio Desktop - [Basic stuff.sm_].png
2014-07-14 19_21_05-SMath Studio Desktop - [Basic stuff.sm_].png
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.