Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

3 Pages<123
Options
Go to last post Go to first unread
Offline Davide Carpi  
#41 Posted : 17 January 2018 10:48:45(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,406
Man
Italy
Location: Italy

Was thanked: 1201 time(s) in 792 post(s)
Originally Posted by: dacts Go to Quoted Post
is it possible to run it on ubuntu 17.10 using mono?, I can't get it to work, when I try to evaluate "CoolProp_get_global_param_string("version"Wink" I just get a little yellow message under the command that reads "CoolProp_x64", or do I need to compile the coolprop binaries ins some specific folder or is it a standalone plugin-extension?


The plug-in it's composed by 3 files, the SMath wrapper plus 2 coolprop libraries (one for x86 systems, the other for x64 ones); according to this issue, it should be possible if you compile the coolprop library (the core) in your machine and then you replace the one shared within this plugin.
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Offline uni  
#42 Posted : 18 June 2020 20:56:52(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
Updated.

Changes: refactored.
Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
thanks 1 user thanked uni for this useful post.
on 19/06/2020(UTC)
Offline ElSid  
#43 Posted : 11 February 2021 10:05:01(UTC)
ElSid


Rank: Advanced Member

Groups: Registered
Joined: 05/03/2009(UTC)
Posts: 424
Man
United States
Location: USA

Was thanked: 15 time(s) in 13 post(s)
Originally Posted by: uni Go to Quoted Post
Updated.
Changes: refactored.

I just started playing with this tool, so please be patient with my ignorance.

Updated to what? The version on my system is 6.1.0; however, the CoolProp website is on 6.4.1
I've also noticed that some of the description paramater names fail.
Screenshot 2021-02-11 015712.png
In addition, off of other threads, there appears to be "commands" that are no longer valid. An example would be FProp here.. Please advise.

I'm still searching for information as to what the other functions do (e.g. CoolProp_get_param_index)

Offline uni  
#44 Posted : 11 February 2021 14:29:51(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
Originally Posted by: Davide Carpi Go to Quoted Post
The plug-in it's composed by 3 files, the SMath wrapper plus 2 coolprop libraries (one for x86 systems, the other for x64 ones)

The plugin consists of two parts: a wrapper and a library. I didn't change the library, I just updated the wrapper source code.
It is possible to update the library version. I don't know where the documentation is and how the set of parameters changes depending on the version.

Edited by user 11 February 2021 14:31:22(UTC)  | Reason: Not specified

Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
Offline ElSid  
#45 Posted : 11 February 2021 16:24:03(UTC)
ElSid


Rank: Advanced Member

Groups: Registered
Joined: 05/03/2009(UTC)
Posts: 424
Man
United States
Location: USA

Was thanked: 15 time(s) in 13 post(s)
Originally Posted by: uni Go to Quoted Post
Originally Posted by: Davide Carpi Go to Quoted Post
The plug-in it's composed by 3 files, the SMath wrapper plus 2 coolprop libraries (one for x86 systems, the other for x64 ones)

The plugin consists of two parts: a wrapper and a library. I didn't change the library, I just updated the wrapper source code.
It is possible to update the library version. I don't know where the documentation is and how the set of parameters changes depending on the version.

What is the correct location for the wrapper? From the 1st post, these are invalid
Quote:
Official SMath wrapper (you have to build it by yourself, instructions in his documentation)

I may take a crack at compiling the newer version
Offline uni  
#46 Posted : 11 February 2021 17:08:59(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
I can update the whole plugin including the library if you need.
Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
Offline ElSid  
#47 Posted : 11 February 2021 19:40:37(UTC)
ElSid


Rank: Advanced Member

Groups: Registered
Joined: 05/03/2009(UTC)
Posts: 424
Man
United States
Location: USA

Was thanked: 15 time(s) in 13 post(s)
Originally Posted by: uni Go to Quoted Post
I can update the whole plugin including the library if you need.

That would be appreciated. Version 6.1.0 is from 2016 and 6.4.1 is Aug. 2020.
On another post (by you), there seemed to be a relation with MathCad. In Sourceforge, MathCad and Prime are compiled by the CoolProp group. Could those files be used so we can just update the few dll files?
https://sourceforge.net/...op/files/CoolProp/6.4.1/
https://sourceforge.net/.../files/CoolProp/nightly/

Edited by user 11 February 2021 21:37:40(UTC)  | Reason: Added SMath Blog mentioning MathCAD for CoolProp

Offline uni  
#48 Posted : 12 February 2021 07:14:30(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
Originally Posted by: ElSid Go to Quoted Post
On another post (by you), there seemed to be a relation with MathCad. In Sourceforge, MathCad and Prime are compiled by the CoolProp group. Could those files be used so we can just update the few dll files?

Yes, you can use these libraries, but this is not a good idea. Better to use direct way.
Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
Offline uni  
#49 Posted : 12 February 2021 08:12:20(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
Sources

Updated. Please try.

Changes:

- CoolProp library updated to 6.4.1;
- refactored.

Originally Posted by: ElSid Go to Quoted Post
What is the correct location for the wrapper? From the 1st post, these are invalid

Code:
%appdata%\SMath\extensions\plugins\ca92ef03-c7da-4888-98ad-528482733e2f

Edited by user 12 February 2021 09:05:15(UTC)  | Reason: Not specified

Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
thanks 1 user thanked uni for this useful post.
on 13/02/2021(UTC)
Offline bbate  
#50 Posted : 19 June 2021 02:11:35(UTC)
bbate

Rank: Newbie

Groups: Registered
Joined: 21/11/2018(UTC)
Posts: 4
Canada
Location: Langley, BC

Was thanked: 1 time(s) in 1 post(s)
I am now getting the following error when using the CoolProp incompressible fluids library call

Initialize failed for backend: "?", fluid: "INCOMP::MEG-50%" fractions "[1.0000000 ]"; error: key [INCOMP::MEG-50%] was not found in string_to_index_map in JSONFluidLibrary : PropsSI("D","T",288.15,"P",101325.3532,"INCOMP::MEG-50%" )

This call was working March of this year. Any suggestions on what may be causing this issue?

Using:
CoolProp Wrapper Plugin 6.1.7713.14622
Smath Version: Smath Studio Desktop 64-bit, 0.99 (build: 7822)
CoolProp Version: CoolProp_v6.4.1.0

Edited by user 19 June 2021 02:13:50(UTC)  | Reason: Not specified

Offline uni  
#51 Posted : 25 June 2021 12:53:31(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
PropsSI.jpg

PropsSI() function is from another plugin (mcadefi + mathcad coolprop lib).

CoolProp_Props.jpg

CoolProp_Props.jpg

Edited by user 25 June 2021 15:48:05(UTC)  | Reason: Not specified

Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
thanks 1 user thanked uni for this useful post.
on 25/06/2021(UTC)
Offline bbate  
#52 Posted : 28 August 2021 01:22:19(UTC)
bbate

Rank: Newbie

Groups: Registered
Joined: 21/11/2018(UTC)
Posts: 4
Canada
Location: Langley, BC

Was thanked: 1 time(s) in 1 post(s)
App Version: "0.99.7822.147"
Windows 10 Pro 64-bit

Issue: CoolProp Plugin functions not recognized by Smath

What I've tried:
- Adding/removing CoolProp Plugin (through the Extensions Manager in Smath Studio Desktop)
- re-installed SMATH Studio; deleting plugin folder after uninstall
- Re-installing CoolProp

Could you please provide guidance on what may be causing this issue?


thanks 1 user thanked bbate for this useful post.
on 28/08/2021(UTC)
Offline uni  
#53 Posted : 28 August 2021 08:01:45(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
The reason for this behavior has not yet been clarified. Use this library for now, replacing the original one (\extensions\plugins\ca92ef03-c7da-4888-98ad-528482733e2f\x.x.x.x\).

CoolPropWrapper-6.4.7910.17946.zip (2,606kb) downloaded 9 time(s).

Edited by user 28 August 2021 08:06:12(UTC)  | Reason: Not specified

Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
Offline bbate  
#54 Posted : 02 September 2021 23:11:40(UTC)
bbate

Rank: Newbie

Groups: Registered
Joined: 21/11/2018(UTC)
Posts: 4
Canada
Location: Langley, BC

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: uni Go to Quoted Post
The reason for this behavior has not yet been clarified. Use this library for now, replacing the original one (\extensions\plugins\ca92ef03-c7da-4888-98ad-528482733e2f\x.x.x.x\).

CoolPropWrapper-6.4.7910.17946.zip (2,606kb) downloaded 9 time(s).


I've downloaded the .dll you provided and placed it in the plugins folder.
I get the following error message when I open Smath:

[img=https://ibb.co/mXxrqD6]PluginError[/img]

Edited by user 02 September 2021 23:13:53(UTC)  | Reason: Not specified

Offline uni  
#55 Posted : 03 September 2021 10:14:56(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
You need to place it here:
Code:
%appdata%\SMath\extensions\plugins\ca92ef03-c7da-4888-98ad-528482733e2f\6.4.7910.14793\


The last numbers may vary. This is the plugin folder. After replacing the file (CoolPropWrapper.dll), everything should work.
Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
Offline uni  
#56 Posted : 03 September 2021 12:56:54(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
SMath Studio compatibility

Plugin updated.

Changes:
- all function's classes now marked as public.

It should work now. You can update the plugin.
Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
thanks 1 user thanked uni for this useful post.
on 03/09/2021(UTC)
Offline Razonar  
#57 Posted : 03 September 2021 18:55:30(UTC)
Razonar


Rank: Advanced Member

Groups: Registered
Joined: 28/08/2014(UTC)
Posts: 813
Uruguay

Was thanked: 433 time(s) in 282 post(s)
Originally Posted by: uni Go to Quoted Post
SMath Studio compatibility

Plugin updated.

Changes:
- all function's classes now marked as public.

It should work now. You can update the plugin.


Hi Viacheslav, thanks, it works. But there are an small issue with the unicode strings

Clipboard01.jpg

Best regards.
Alvaro.
thanks 1 user thanked Razonar for this useful post.
on 03/09/2021(UTC)
Offline uni  
#58 Posted : 03 September 2021 21:32:39(UTC)
uni


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 10/11/2010(UTC)
Posts: 1,165
Man
Russian Federation

Was thanked: 1008 time(s) in 585 post(s)
Okay, you caught me.

Plugin updated. Try now.

2021-09-03_23-34-35.png

Edited by user 03 September 2021 21:35:08(UTC)  | Reason: Not specified

Russia ☭ forever
Viacheslav N. Mezentsev
💰 Support me for plugins development: https://yoomoney.ru/to/410013245578758
thanks 1 user thanked uni for this useful post.
on 04/09/2021(UTC)
Offline Razonar  
#59 Posted : 04 September 2021 00:21:53(UTC)
Razonar


Rank: Advanced Member

Groups: Registered
Joined: 28/08/2014(UTC)
Posts: 813
Uruguay

Was thanked: 433 time(s) in 282 post(s)
Hi. Great! Now the demo file in the first post works perfect.

Best regards.
Alvaro.
Users browsing this topic
3 Pages<123
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.