Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

3 Pages123>
Options
Go to last post Go to first unread
Offline kda406  
#1 Posted : 22 March 2013 17:28:18(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

When I try to save a simple page it crashes SMath with a "Attempted to divide by zero." error. I got this error with the portable and installed version. The page works great until I try to save. I have attached a screen shot.
Thanks,
Kyle
kda406 attached the following image(s):
SmathDBZ.png
Offline Davide Carpi  
#2 Posted : 22 March 2013 17:54:12(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,418
Man
Italy
Location: Italy

Was thanked: 1203 time(s) in 794 post(s)
Hi,

could you attach the file?


regards,

w3b5urf3r
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Offline kilele  
#3 Posted : 22 March 2013 18:44:50(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
Originally Posted by: w3b5urf3r_reloaded Go to Quoted Post
Hi,

could you attach the file?




Biggrin yes, can you attach it ?
this is my version of your sheet, please tell us if you can run and save it.

File Attachment(s):
Page1.sm (6kb) downloaded 45 time(s).
Offline kda406  
#4 Posted : 22 March 2013 19:57:13(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: w3b5urf3r_reloaded Go to Quoted Post
Hi,

could you attach the file?


regards,

w3b5urf3r


Sure, it's attached. It won't open for me.
Thanks,
Kyle
File Attachment(s):
CapacitorRippleVoltage.sm (2kb) downloaded 47 time(s).
Offline kda406  
#5 Posted : 22 March 2013 19:59:09(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: kilele Go to Quoted Post

Biggrin yes, can you attach it ?
this is my version of your sheet, please tell us if you can run and save it.


Thanks for the sample file. It does not open correctly for me. When I double click your file, I get what you see in the attached screen shot.
Thanks,
Kyle

EDIT: I get the same problem below from your file in both installed and portable version.

Edited by user 22 March 2013 20:00:59(UTC)  | Reason: Not specified

kda406 attached the following image(s):
SMS-Kilele.PNG
Offline kilele  
#6 Posted : 22 March 2013 21:43:45(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
There might be some problem with the TextRegion.dll plugin.
You may want to make a clean uninstall of SMath with some of this programs, all of them available for free at portableapps.com
ZSoftUninstaller, IObitUninstaller, WiseRegistryCleaner.
Offline Davide Carpi  
#7 Posted : 22 March 2013 21:45:46(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,418
Man
Italy
Location: Italy

Was thanked: 1203 time(s) in 794 post(s)
Originally Posted by: kda406 Go to Quoted Post
Sure, it's attached. It won't open for me.
Thanks,
Kyle


The file is broken - probably becasue the "Attemted to divide by zero" error has stopped the saving routines, but I'm not sure because last line is in the file header (TextRegion plugin), not in the body...

The kilele file works for me; if both install and portable versions cause you issues you can try to install again the .NET framework 2.0 libraries. What OS are you using? Windows XP x86/x64 SP1/2/3?
Davide Carpi attached the following image(s):
CUsersDavideDesktopCapacitorRippleVoltage.sm - Notepad++_2.png
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Offline kda406  
#8 Posted : 22 March 2013 22:03:57(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: w3b5urf3r_reloaded Go to Quoted Post
The file is broken - probably becasue the "Attemted to divide by zero" error has stopped the saving routines, but I'm not sure because last line is in the file header (TextRegion plugin), not in the body...

The kilele file works for me; if both install and portable versions cause you issues you can try to install again the .NET framework 2.0 libraries. What OS are you using? Windows XP x86/x64 SP1/2/3?

This machine runs XP Pro x86 SP3 and has .NET 2.0, 3.0, 3.5, and 4 installed. .NET 2.0 has Service Pack 2.
Thanks,
Kyle

Offline kda406  
#9 Posted : 22 March 2013 22:12:24(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: kilele Go to Quoted Post
There might be some problem with the TextRegion.dll plugin.

I have only one copy of TextRegion.dll on my computer. It is located in C:\Program Files\SMath\SMath Studio\plugins. It is 23552 bytes in size and was made on July 30, 2012, 12:03:58AM.

I uninstalled SMath Studio, and made sure the directory was removed (it was gone). I downloaded a fresh copy of the .msi installer and reinstalled. Same problems. Sad
Thanks,
Kyle

Offline kilele  
#10 Posted : 23 March 2013 01:10:22(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
Kyle, I suggested to use some of the uninstallers above because I had problems with an old SMath version which always disabled a plugin when loading. This kind of programs not only remove the installed files but also search for leftovers on the registry, this seemed to make SMath load with all plugins.
Another thing that you could try is to install SMath in a different location than default, and also install several versions of SMath. Good luck!
Offline kda406  
#11 Posted : 27 March 2013 23:22:28(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

I tried uninstalling and reinstalling in a different directory. This did not solve the problem.

I uninstalled SMath altogether.

I ran Piriform CCleaner (here) and ran the registry cleaner and rebooted 3 times before all problems were fixed. All "problems" were minor and the result of uninstalled 3D CAD systems. I cleaned them all up until the computer rebooted, checked, and claimed "no problems."

I installed 0.95.4594 again, and still have the exact same problem reading Kilele's Page1.sm. Hysterics

New info==> When I click Help -> About, I get a divide by zero error. This happens with both a new, blank page, and if I have Kilele's Page1.sm file open.

Thanks for all the help guys,
Kyle
Offline kilele  
#12 Posted : 28 March 2013 03:20:17(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
You can try to install .Net4.5
and also update the other .Net libraries present on your system. This should fix the problem Biggrin

Edit:

My last shot, take the file TextRegion.dll out of its directory and run SMath, put it back and see if the problem is gone.

Edited by user 28 March 2013 16:07:55(UTC)  | Reason: Not specified

Offline kda406  
#13 Posted : 28 March 2013 16:10:47(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Unfortunately, .Net 4.5 is not available for my XP Pro SP3. Wallbash
Thanks,
Kyle
Offline kilele  
#14 Posted : 28 March 2013 16:21:50(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
well actually SMath works with .net2 apart from the DataExchange plugin which has versions for .net2 and .net35, though later .net frameworks might have some effect on previous ones. Maybe you could find some update for these two .net versions from windows update of your operating system.
Offline kda406  
#15 Posted : 28 March 2013 16:45:25(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: kilele Go to Quoted Post
My last shot, take the file TextRegion.dll out of its directory and run SMath, put it back and see if the problem is gone.

I missed the edit earlier. I just tried this and it gives me the same drawing error after following your instructions. (Also the same divide by zero error when trying to view Help -> About)

Thanks,
Kyle

Offline Davide Carpi  
#16 Posted : 28 March 2013 16:59:58(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,418
Man
Italy
Location: Italy

Was thanked: 1203 time(s) in 794 post(s)
Have you tried if the issue affects also older SMath Studio versions? 0.95, 0.94, 0.93, 0.92....
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
Offline kilele  
#17 Posted : 28 March 2013 17:07:09(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
I've noticed that if you delete some dlls, a reconfiguration window is brought up by SMath and the files are restored, I assume they are extracted from the program's exe. As a last resort, apart from upgrading .Net20, you may want to replace some files from your installation with these of mine:
https://dl.dropbox.com/u...ract_to_smath_folder.zip
Offline kda406  
#18 Posted : 28 March 2013 18:55:31(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: kilele Go to Quoted Post
Maybe you could find some update for these two .net versions from windows update of your operating system.


"Windows Update" shows no updates available for my machine. This workstation is fully patched as far as I can tell. Looking at "Add or Remove Programs":

Microsoft .NET Framework 2.0 Language Pack - DEU
Microsoft .NET Framework 2.0 Service Pack 2 v2.2.30729

Microsoft .NET Framework 3.0 Service Pack 3 v3.2.30729

Microsoft .NET Framework 3.5 SP1

Microsoft .NET Framework 4 Client Profile v4.0.30319
Microsoft .NET Framework 4 Extended v4.0.30319

Thanks,
Kyle
Offline kda406  
#19 Posted : 28 March 2013 19:01:21(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: w3b5urf3r_reloaded Go to Quoted Post
Have you tried if the issue affects also older SMath Studio versions? 0.95, 0.94, 0.93, 0.92....


I see I neglected to mention above I downloaded and tried an earlier version and it had the same problems. I think it was 0.93 (sorry I didn't keep it to remember).

I will try the files in the zip next...

Thanks,
Kyle
Offline kda406  
#20 Posted : 28 March 2013 19:11:57(UTC)
kda406


Rank: Member

Groups: Registered
Joined: 22/03/2013(UTC)
Posts: 20
Man
United States
Location: Atlanta, GA

Originally Posted by: kilele Go to Quoted Post
I've noticed that if you delete some dlls, a reconfiguration window is brought up by SMath and the files are restored, I assume they are extracted from the program's exe. As a last resort, apart from upgrading .Net20, you may want to replace some files from your installation with these of mine:


Your plugins directory had tons of files which mine did not have. I extracted your and told Winzip to overwrite mine. Then I noticed you included some .sm files in the plugins directory. I opened the larger one in SMath, which you can see in the attached.

Thanks,
Kyle
kda406 attached the following image(s):
SM2.PNG
Users browsing this topic
3 Pages123>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.