Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Davide Carpi  
#1 Posted : 14 September 2012 17:46:29(UTC)
Davide Carpi


Rank: Advanced Member

Groups: Registered, Advanced Member
Joined: 13/01/2012(UTC)
Posts: 2,523
Man
Italy
Location: Italy

Was thanked: 1267 time(s) in 833 post(s)
Hi all,

I've found on the net this plugin: math.net numerics;

the plugin contains a lot of useful functions:

Code:
Random Numbers
    Probability Distributions
    Statistics
    Linear Algebra
    Special Functions
    Interpolation
    Integration
    Integral Transforms (FFT etc.)
    Number Theory
    Combinatorics


And the license seem full compatible with SMath...

But seem that the framework is not compatible (.NET framework 4)... loading a plugin with a random function based on the math.net numerics plugin SMath disable the plugin (something like: "Can't load the assembly because it's created from a runtime newer than the currently loaded")

there is a way to bypass this issue?


regards,

w3b5urf3r
Davide Carpi attached the following image(s):
error.PNG
If you like my plugins please consider a donation to SMath Studio; for personal contributions to me: paypal.me/dcprojects
thanks 1 user thanked Davide Carpi for this useful post.
on 14/09/2012(UTC)
Offline omorr  
#2 Posted : 14 September 2012 20:16:19(UTC)
omorr


Rank: Administration

Groups: Registered, Administrators, Advanced Member
Joined: 23/06/2009(UTC)
Posts: 1,740
Man
Serbia

Was thanked: 318 time(s) in 268 post(s)
Hello w3b5urf3r,

I am quite sure that someone mentioned this library here some time ago. I can not find it by searching the Forum at the moment.

Among other things, plugin with Statistical distributions and functions are one of my wishes for SMath Good

If you could manage it to work - you would be my superhero Good

Regards,
Radovan

Edited by user 14 September 2012 20:18:35(UTC)  | Reason: Not specified

When Sisyphus climbed to the top of a hill, they said: "Wrong boulder!"
Offline kilele  
#3 Posted : 19 September 2012 18:36:01(UTC)
kilele


Rank: Advanced Member

Groups: Registered
Joined: 30/03/2011(UTC)
Posts: 393

Was thanked: 132 time(s) in 113 post(s)
Originally Posted by: omorr Go to Quoted Post
Hello w3b5urf3r,

I am quite sure that someone mentioned this library here some time ago. I can not find it by searching the Forum at the moment.



There you have Blush

I hope that Andrey can help you to compile this library, it is not compatible with windowsMobile (NET2.0) but I guess there won't be a new version for that platform.
Anyway this code or part of it might be adapted to NET2.0, I don't think it is worth the effort though.

Edited by user 19 September 2012 18:55:55(UTC)  | Reason: Not specified

thanks 1 user thanked kilele for this useful post.
on 19/09/2012(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.